Theme in themes.local stopped working

Post plugins and custom CSS snippets here
Latimer
Bear Rating Master
Bear Rating Master
Posts: 130
Joined: 17 Mar 2013, 19:35

Theme in themes.local stopped working

Postby Latimer » 13 Feb 2017, 00:25

I updated my instance of tt-rss to 454292b2, and my custom theme stopped working.

The theme file is located in /themes.local. I updated it to account for the version change, and to import the default theme from default.php instead of default.css, but it doesn't seem to be able to actually import the default theme. Later I moved the updated theme file to /themes, and it started working.

What would be the best way to fix my custom theme while still using /themes.local as a storage directory?

User avatar
fox
^ me reading your posts ^
Posts: 6272
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Theme in themes.local stopped working

Postby fox » 13 Feb 2017, 08:05

does it try to import default.css which is now default.php?

e: oh right, hmm

well i made a sample theme containing the following. i could select it in preferences and it applied fine.

Code: Select all

/* supports-version:17.1 */

@import "../themes/default.php";

body { background : black ! important; }

Latimer
Bear Rating Master
Bear Rating Master
Posts: 130
Joined: 17 Mar 2013, 19:35

Re: Theme in themes.local stopped working

Postby Latimer » 14 Feb 2017, 06:29

Code: Select all

@import "../themes/default.php";

this did the trick, thanks


Return to “Themes and plugins”

Who is online

Users browsing this forum: No registered users and 2 guests