1.8 and SMTP_SECURE

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
decoherent
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 12 Jun 2013, 18:15

1.8 and SMTP_SECURE

Postby decoherent » 12 Jun 2013, 18:22

I just updated from 1.7.9 to 1.8 via the CLI ("php ./update.php --update-self" as www-data), but now I'm getting a startup error. Specifically, I'm getting the "Startup Failed" screen with the error:

Code: Select all

Required configuration file parameter SMTP_SECURE is not defined in config.php. You might need to copy it from config.php-dist.

OK, this seems pretty straight-forward. However, there's no mention of SMTP_SECURE in config.php-dist. Well, fine, I think, I'll just add it to config.php anyway. In the SMTP section (which I don't use), I added:

Code: Select all

define('SMTP_SECURE', '');

However, I'm still getting the same Startup Failed message. I can't find any mention of SMTP_SECURE on the wiki or the forums, so I don't know if I'm supposed to pass it some other option.

This machine is Nginx on Debian. I tried reloading nginx, but that didn't seem to help either. Can anyone give me a suggestion?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: 1.8 and SMTP_SECURE

Postby fox » 12 Jun 2013, 18:31

something got screwed up while updating. Get a release tarball and replace all the files except for config.php.

decoherent
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 12 Jun 2013, 18:15

Re: 1.8 and SMTP_SECURE

Postby decoherent » 12 Jun 2013, 18:36

Thanks, yeah, I see that I didn't have the most recent version of config.php-dist, and thus probably other files. I replaced everything and now it starts fine (well, once I fixed my access level according to the FAQ). Thanks!

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: 1.8 and SMTP_SECURE

Postby oliroe » 12 Jun 2013, 20:52

Hmmm, I've got the same error message so it doesn't look like an isolated case. I updated through the updater plugin on a new install

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: 1.8 and SMTP_SECURE

Postby fox » 12 Jun 2013, 20:59

The only thing updater does is downloads exactly same tarball and extracts it in the new directory. If you can replicate this and figure out why it happens, it would be great, because I'm just not seeing it.

XianPalin
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 16 May 2013, 23:10

Re: 1.8 and SMTP_SECURE

Postby XianPalin » 12 Jun 2013, 21:10

Might be wrong here, but isn't the problem that it's a new requirement to be defined in config.php?

The updater doesn't overwrite your config file. Since your config file isn't being changed, you're not getting the new required SMTP_SECURE line that is now needed.

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: 1.8 and SMTP_SECURE

Postby oliroe » 12 Jun 2013, 22:01

@XianPalin

You're quite right, adding define('SMTP_SECURE', ''); to my config.php solved the issue. Sorry for wasting your time

rikels
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 02 Jun 2013, 13:51

Re: 1.8 and SMTP_SECURE

Postby rikels » 12 Jun 2013, 22:15

you get more errors like these when updating. just open the config.php-dist, and find the missing line, and copy it over to about the same place in your own config.php file. i did this on 2 updates, and it seems to work.

hereschenes
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 13 Jun 2013, 16:10

Re: 1.8 and SMTP_SECURE

Postby hereschenes » 13 Jun 2013, 16:12

oliroe wrote:@XianPalin

You're quite right, adding define('SMTP_SECURE', ''); to my config.php solved the issue. Sorry for wasting your time

Thanks for posting this - I had the same issue (was the first time I've updated tt-rss). All good now.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests