LibXML errors the past few days

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

Re: LibXML errors the past few days

Postby smeerbartje » 09 May 2014, 15:07

Anyhow, adding ?format=xml solved the problem.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 09 May 2014, 15:32

apparently this host sends html if http referrer is set which is default when using curl (referrer is set to the same url string)

i think this is there because there are were idiotic hosts reported which required referrer or something, I see this as a hack so I'm gonna remove it for the time being from trunk

this makes it work without stupid format=xml options

maximevalette
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 10 May 2014, 16:56

Re: LibXML errors the past few days

Postby maximevalette » 10 May 2014, 17:02

Hello,

FeedPress "shitty idiot" CEO here. :)

Brett sent me an email about the issue, and I also talked to Rogier.

As I said to them, we try to do our best to show a browser friendly version of the feed as often as we can (because it's always better to have something to show in Mobile Safari instead of a weird error). This is mostly relying on User Agent detection, but as far as I know, Tiny Tiny RSS is using this User Agent:

Code: Select all

Tiny Tiny RSS/1.11 (http://tt-rss.org/)


And we don't send an HTML version to this kind of UA. So I asked about more details of the TT-RSS implementation in order to find out why we would send an HTML version.

If you can provide me more details, I'd be happy to solve this issue.

maximevalette
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 10 May 2014, 16:56

Re: LibXML errors the past few days

Postby maximevalette » 10 May 2014, 17:07

fox wrote:apparently this host sends html if http referrer is set which is default when using curl (referrer is set to the same url string)


That's in fact the same behaviour with FeedBurner. They send an HTML page if you send a Referer HTTP header.

Anyway, glad it's been fixed.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 10 May 2014, 17:35

maximevalette wrote:Hello,
If you can provide me more details, I'd be happy to solve this issue.


I like how the solution is right there above your post.

e: I'm not going to comment on design which prioritizes referrer over user agent.

maximevalette
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 10 May 2014, 16:56

Re: LibXML errors the past few days

Postby maximevalette » 10 May 2014, 17:37

fox wrote:I like how the solution is right there above your post.


Hence the second post.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest