1.2.21: Your access level is insufficient to run this script

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
Benni
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 16 Feb 2008, 12:07

1.2.21: Your access level is insufficient to run this script

Postby Benni » 29 Mar 2008, 14:18

Hi there,

recently I had a strange problem with TT-RSS.

I used version 1.2.20 and when 1.2.21 got released I downloaded it, checked the config.php for modifications with WinMerge, merged them where necessary and uploaded the whole folder.

But there the problem begins. When I try to login I get redirected to update.php and the message "Your access level is insufficient to run this script." appears.

I have TT-RSS configured for multiuser-use and I´m the only user of it with the admin-account.

Perhaps you can help me?

Benni

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Postby fox » 29 Mar 2008, 16:04

That's weird. Are you sure your access level isn't screwed up in the DB? You can check it with sql console, table/column: ttrss_users/access_level.

Also, try removing tt-rss cookies, maybe something screwed up your session.

If all else fails, you can apply the differences manually through the console, the relevant files are in schema/versions/(mysql or pgsql). It would be better in the long run to figure what went wrong, though.

Benni
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 16 Feb 2008, 12:07

Postby Benni » 29 Mar 2008, 18:13

Well, I cleared the cookies, but nothing happens.

when I take a look into the database where you told I can see that my access level is set to 0.

I don´t know if this was like that before the update or not, but somehow I think there´s the cause for the warning.

What number should I insert to get full access again?

Benni

Benni
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 16 Feb 2008, 12:07

Postby Benni » 29 Mar 2008, 18:27

Sorry for the second post.

---

I found the code which shows this warning. It´s in update.php from line 27 to 31:

Code: Select all

   if (!SINGLE_USER_MODE && $_SESSION["access_level"] < 10) {
      $_SESSION["login_error_msg"] = __("Your access level is insufficient to run this script.");
      render_login_form($link);
      exit;
   }

Now I changed my access level in the database to 10 and the update went well.

Benni

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Postby fox » 29 Mar 2008, 23:54

Good. It's really weird that it got set to zero, though.

User avatar
Steve`
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 20 Apr 2008, 12:00
Location: Germany
Contact:

Postby Steve` » 20 Apr 2008, 12:03

Hi there,

I had the same problems today and fixed them by changing the access level.

jd2066
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 09 Apr 2007, 13:37

Postby jd2066 » 21 Apr 2008, 05:48

I had this problem for the last few versions.
I just kept switching to single user mode to upgrade and then switching back to multiuser mode.
Glad to see there is a better solution.

cgarvey
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 10 Jun 2008, 03:54

Re: 1.2.21: Your access level is insufficient to run this script

Postby cgarvey » 10 Jun 2008, 03:59

Had the same error (and the sql fix worked) upgrading to 1.2.23

jsdm
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 27 Apr 2010, 21:37

Re: 1.2.21: Your access level is insufficient to run this script

Postby jsdm » 07 Oct 2010, 05:00

I had this problem updating my multiuser installation from 1.3.3 to 1.4.3 just now. My access_level was 5 and it needed to be 10.

Documenting specifically what I did to help anybody in the future who isn't mysql savvy:
mysql -u <sqluser> -p <dbname>
Password: <sqlpasswd>
update ttrss_users set access_level=10 where login = '<ttuser>';
exit

Where <sqluser> and <sqlpasswd> and <dbname> are specified as DB_USER and DB_PASS and DB_NAME in config.php and <ttuser> is the account name used to log into tt-rss.

salyavin
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 25 Mar 2013, 04:02
Location: 日本長崎県 

Re: 1.2.21: Your access level is insufficient to run this sc

Postby salyavin » 25 Mar 2013, 14:01

Just had this happen to me for my first upgrade from 1.7.4 to 1.75 with postgresql but this included SQL fix worked just great.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests