ompl import - apache error I/O warning

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
tk421storm
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 02 Apr 2013, 21:10

ompl import - apache error I/O warning

Postby tk421storm » 09 Dec 2014, 22:32

Hey all -

I'm trying to import my feeds OPML (exported from ttrss before update), but I'm getting an empty window "Processing category: Uncategorized" and the following error in my apache log:

[tt-rss] E_WARNING (2) (classes/opml.php:494) DOMDocument::load(): I/O warning : failed to load external entity "/**ttrssInstallLocation**/cache/upload/opmlgJosYL"

Something wrong with the uploading function? the cache/upload folder has 777 permissions.

Thanks!!

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: ompl import - apache error I/O warning

Postby fox » 09 Dec 2014, 22:48

i might have broken opml import with that security fix although it is unlikely

e: looks like it :(

tk421storm
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 02 Apr 2013, 21:10

Re: ompl import - apache error I/O warning

Postby tk421storm » 09 Dec 2014, 22:50

I am working with 1.15, dated December 8 2014. So fresh!

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: ompl import - apache error I/O warning

Postby fox » 09 Dec 2014, 22:55

well, it's a very easy fix: https://github.com/gothfox/Tiny-Tiny-RS ... 1509230c93

maybe a few other dom-related things broke too, we shall see i guess.

i'll sticky this for the time being.

tk421storm
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 02 Apr 2013, 21:10

Re: ompl import - apache error I/O warning

Postby tk421storm » 09 Dec 2014, 23:19

Confirmed that fixed it for me!! Thanks.

User avatar
pahles
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 20 Mar 2013, 17:02

Re: ompl import - apache error I/O warning

Postby pahles » 18 Apr 2015, 00:10

OPML import is still not working for me.

I'm on the latest release (using Git), Postgresql 9.3, PHP 5.5 on Ubuntu 14.04. I'm using nginx however as webserver. No error messages in nginx logging. Any ideas?

JustAMacUser
Bear Rating Overlord
Bear Rating Overlord
Posts: 373
Joined: 20 Aug 2013, 23:13

Re: ompl import - apache error I/O warning

Postby JustAMacUser » 18 Apr 2015, 21:49

Have you tried looking at the PHP error log? By default TT-RSS logs errors in the database; so login as the admin user, go to preferences and check the logs there.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests