Help with filters

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Help with filters

Postby SimbaLion » 07 Jul 2015, 02:08

Hi, I'm not sure what I'm doing wrong.

I've got one filter which matches some simple strings and stars posts with those words or strings. I've got another filter which matches unwanted strings and deletes posts with those strings, however, posts with the unwanted strings are still showing up.

At first, the delete filter was at the top of the order, and when it wasn't working, I tried moving it to the bottom of the order, and it still isn't working. Matching is happening properly according to tests.

Any help is appreciated.

JustAMacUser
Bear Rating Overlord
Bear Rating Overlord
Posts: 373
Joined: 20 Aug 2013, 23:13

Re: Help with filters

Postby JustAMacUser » 07 Jul 2015, 03:50

Maybe post the regex for us to take a look.

SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Re: Help with filters

Postby SimbaLion » 07 Jul 2015, 04:17

JustAMacUser wrote:Maybe post the regex for us to take a look.


How would that help? As I said, matching is working properly according to tests.

The regex are things like:

Starred: (blue|red|green)
Deleted: (anxiety|violence|greed)

As I said, very simple string searches.

JustAMacUser
Bear Rating Overlord
Bear Rating Overlord
Posts: 373
Joined: 20 Aug 2013, 23:13

Re: Help with filters

Postby JustAMacUser » 07 Jul 2015, 05:34

Because the "test" button and the actual matching during feed fetching perform differently and depending on syntax one may work while the other doesn't.

So, post your real filters and we can maybe help.

SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Re: Help with filters

Postby SimbaLion » 07 Jul 2015, 06:03

JustAMacUser wrote:Because the "test" button and the actual matching during feed fetching perform differently and depending on syntax one may work while the other doesn't.

So, post your real filters and we can maybe help.


I did post my real filters.

JustAMacUser
Bear Rating Overlord
Bear Rating Overlord
Posts: 373
Joined: 20 Aug 2013, 23:13

Re: Help with filters

Postby JustAMacUser » 07 Jul 2015, 06:56

What about the rest of your settings: invert, match all, etc.? What field(s) are you trying to match (content, title, etc.)? What are those set to?

If you change the delete rule to star, do the articles then get starred or are they still unmatched?

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Help with filters

Postby sleeper_service » 07 Jul 2015, 07:38

it's pretty obvious that he doesn't WANT help :D

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Help with filters

Postby fox » 07 Jul 2015, 08:09

f D on a feed in question would open feed debugger, post logs here, op

SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Re: Help with filters

Postby SimbaLion » 07 Jul 2015, 08:42

fox wrote:f D on a feed in question would open feed debugger, post logs here, op


I'm sorry I dont understand what f D means, is that a setting somewhere? If there's a way to see logs of the filtering I'll probably be able to solve this on my own.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Help with filters

Postby fox » 07 Jul 2015, 08:50

it's a keyboard shortcut you use while the feed is open in tt-rss

when the debugger opens check both checkboxes

SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Re: Help with filters

Postby SimbaLion » 08 Jul 2015, 22:23

Thank you, I gave that a try and while examining the log it occured to me, the posts which have slipped past the filter tend to be several paragraphs, with the filtered word appearing at the very end. Perhaps the issue is that the xml feed does not itself contain the filtered word.

I am going to test using a string of words from the top of the post, this is from a known spammer so it is always the same line of text.

Do I need to escape punctuation? In this case a question mark appears mid-string.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Help with filters

Postby fox » 08 Jul 2015, 23:00

it is regular expressions so i'd say yes, ? is a operator

JustAMacUser
Bear Rating Overlord
Bear Rating Overlord
Posts: 373
Joined: 20 Aug 2013, 23:13

Re: Help with filters

Postby JustAMacUser » 09 Jul 2015, 00:13

Do I need to escape punctuation? In this case a question mark appears mid-string.


... So I guess those were not your real regex values... ;-)

Just saying, the issue could have been resolved quicker.

SimbaLion
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 07 Jul 2015, 02:04

Re: Help with filters

Postby SimbaLion » 10 Jul 2015, 00:46

fox wrote:it is regular expressions so i'd say yes, ? is a operator


Oh right, I had forgotten. Still, there were no punctuation in my original regex, only simple words.

I'm looking at the log but to be honest I have no idea what I'm looking at, and nothing jumps out at me as the issue, should I post a log excerpt?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Help with filters

Postby fox » 10 Jul 2015, 01:14

there should be a "article filters:" thing which should show filters matching each article

don't forget to check force_rehash btw


Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 4 guests