Enable embedded videos in feeds

Post plugins and custom CSS snippets here
User avatar
dxbi
Bear Rating Disaster
Bear Rating Disaster
Posts: 62
Joined: 16 Mar 2013, 13:44

Enable embedded videos in feeds

Postby dxbi » 25 Mar 2013, 21:02

Hi.

videoframes is a plugin for tt-rss 1.7.5 or later that enables the playback of videos from Youtube and other sites in Tiny Tiny RSS.

Image

For details and installation instructions, please see the github page.

Feedback is most welcome.
Last edited by dxbi on 30 Mar 2013, 23:24, edited 2 times in total.

supersmurf
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 26 Mar 2013, 00:38

Re: Enable embedded videos in feeds

Postby supersmurf » 26 Mar 2013, 00:41

Looks like its working fine here with chrome on youtube clips, thanks for the plugin.

Aldursil
Bear Rating Master
Bear Rating Master
Posts: 106
Joined: 18 Mar 2013, 03:11

Re: Enable embedded videos in feeds

Postby Aldursil » 26 Mar 2013, 05:24

Works here as well. Thanks!

User avatar
Andyt8
Bear Rating Disaster
Bear Rating Disaster
Posts: 83
Joined: 19 Mar 2013, 17:02
Location: Austria
Contact:

Re: Enable embedded videos in feeds

Postby Andyt8 » 26 Mar 2013, 13:34

Perfectly, instead of a black box I see the flash video. Thanks...

User avatar
dxbi
Bear Rating Disaster
Bear Rating Disaster
Posts: 62
Joined: 16 Mar 2013, 13:44

Re: Enable embedded videos in feeds

Postby dxbi » 27 Mar 2013, 15:05

I've pushed a new version that will replace "old" <object><embed></object> style flash videos with their iframe counterpart. This now accounts for almost all embedded videos I've encountered in feeds.

If you come across one that does not show up, please let me know.

User avatar
Andyt8
Bear Rating Disaster
Bear Rating Disaster
Posts: 83
Joined: 19 Mar 2013, 17:02
Location: Austria
Contact:

Re: Enable embedded videos in feeds

Postby Andyt8 » 03 Apr 2013, 11:52

Are there a new version for TT-RSS 1.7.6?


edit: Ok, I found my mistake. I needed to re-download the files. They were cached by a Proxy Server or similar. I got only an older version.

User avatar
Monfreid
Bear Rating Trainee
Bear Rating Trainee
Posts: 23
Joined: 04 Apr 2013, 18:16

Re: Enable embedded videos in feeds

Postby Monfreid » 04 Apr 2013, 19:32

Hello,
I have followed the instructions but I can't see the the plugin in the preferences so I can't enable it.
What can I do to fix this?
Thank you

User avatar
dxbi
Bear Rating Disaster
Bear Rating Disaster
Posts: 62
Joined: 16 Mar 2013, 13:44

Re: Enable embedded videos in feeds

Postby dxbi » 04 Apr 2013, 21:10

Is the folder videoframes in your plugins folder? Does it contain the file init.php? Does your webserver have sufficient rights to read both files ("chmod 755 videoframes; chmod 644 videoframes/init.php")?

User avatar
Monfreid
Bear Rating Trainee
Bear Rating Trainee
Posts: 23
Joined: 04 Apr 2013, 18:16

Re: Enable embedded videos in feeds

Postby Monfreid » 05 Apr 2013, 15:21

Hello,

I found out what the problem was ... the videoframes folder was in the plugins folder but inside this folder there was another folder called videoframes and then the init.php file. I think I've done a mistake the way I've unzipped the zip file. I have moved the videoframes folder with the init.php file to the plugins folder and now it works

Thanks for this great plugin :-)

cheers

xalabin
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 06 Apr 2013, 16:01

Re: Enable embedded videos in feeds

Postby xalabin » 06 Apr 2013, 16:05

Hello.
I instaled the plugin ( in the correct path, with correct permissions 755 and 644).
When i try to configure the plugins, the web page does show nothing, just is in blank.
this problem disapears if i delete the plugin.

Someone can help me?

Thanks!

User avatar
dxbi
Bear Rating Disaster
Bear Rating Disaster
Posts: 62
Joined: 16 Mar 2013, 13:44

Re: Enable embedded videos in feeds

Postby dxbi » 06 Apr 2013, 18:45

Please check the error log of your webserver and report any error messages.

xalabin
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 06 Apr 2013, 16:01

Re: Enable embedded videos in feeds

Postby xalabin » 07 Apr 2013, 00:19

Probably it was my mistake.

I was using the 1.7.4 versión of ttrss believeing that it was the 1.7.5
Now i ipgraded to 1.7.8 and all works fine.

Apologize me about the inconveniences.

Aldursil
Bear Rating Master
Bear Rating Master
Posts: 106
Joined: 18 Mar 2013, 03:11

Re: Enable embedded videos in feeds

Postby Aldursil » 08 Apr 2013, 18:16

I just found a video that was not rendered in TTRSS. The link to the original article is below if you wish to implement videofeeds for this video source.

http://crooksandliars.com/john-amato/ga ... -2-dark-wi

jfreake
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 12 Apr 2013, 17:40

Re: Enable embedded videos in feeds

Postby jfreake » 12 Apr 2013, 17:41

Great job man! Works perfect. :D

User avatar
dxbi
Bear Rating Disaster
Bear Rating Disaster
Posts: 62
Joined: 16 Mar 2013, 13:44

Re: Enable embedded videos in feeds

Postby dxbi » 20 Apr 2013, 21:49

@all If you're following trunk you will have to update to the latest version (adding the api_version spec recently added in tt-rrs).
@aldursil Thanks, but I don't think videos from hbo have significant usage numbers in feeds. Eventually I want users to be able to choose which video sites they trust and (temporarily) enable disabled sites using some button embedded into the post itself. But until then, I'll defer adding all but the largest video sources.


Return to “Themes and plugins”

Who is online

Users browsing this forum: No registered users and 5 guests