SecurityError: The operation is insecure

If you run tt-rss on an officially unsupported platform (shared hosting, Windows, etc.) post here
zaan
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 26 Apr 2014, 12:11

SecurityError: The operation is insecure

Postby zaan » 26 Apr 2014, 12:20

For a while now, I get an alert on every login saying the operation is insecure.
Nothing has changed in my setup that I know of, the behavior may have started after an update to tt-rss.
I run my instance with a single user on its own subdomain url. This is on shared hosting.

Code: Select all

EXCEPTION: Exception: [Exception... "The operation is insecure."  code: "18" nsresult: "0x80530012 (SecurityError)"  location: "<unknown>"]
Function: init_second_stage()
Line 128


The exception appears to be triggered on line 548 of the html the browser receives, which is the sessionStorage.clear() portion in the following javascript function:

Code: Select all

function cache_clear(){if(has_storage)
sessionStorage.clear();}


Is there something I can do to my browser or tt-rss install to avoid this?

Thanks.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: SecurityError: The operation is insecure

Postby fox » 26 Apr 2014, 14:45

your browser is probably too secure for tt-rss

zaan
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 26 Apr 2014, 12:11

Re: SecurityError: The operation is insecure

Postby zaan » 28 Apr 2014, 13:19

OK. If that is the problem, how do I resolve or bypass it?

Thanks.


Return to “Unsupported platforms”

Who is online

Users browsing this forum: No registered users and 2 guests