Page 2 of 2

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 19:01
by surfrock66
Lemme try blowing the db away, just to see if it changes anything, and re-importing the xml

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 19:10
by fox
see updated post on p 1

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 19:11
by fox
by the way, if you have backups of your tt-rss database before you switched to git and updated it, it will be really helpful.

e: also, the error was logged in the tt-rss error logging interface, i should've told you to check that too i guess

e2: looks like error checking on schema update just doesn't work on mysql which is really awesome and not at all a critical bug

e3: the above should be fixed now at least

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 22:34
by surfrock66
So, I blew away the DB and reinstalled from git, then pulled my ooml back in...works like a champ. Dunno. Somewhere the DB got borked I guess. I kept the old one, so maybe I can troubleshoot why it went wrong, but otherwise I'm good to go.

I can pull the db out I think if you want the pre-update dump.

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 23:02
by fox
yep, i would appreciate it, i'll run upgrade scripts on it and see if anything breaks

well at least one serious bug got fixed because of this thread so its all good already

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 26 Apr 2016, 23:53
by surfrock66
Sent via PM. Huzzah for bug fixing.

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 27 Apr 2016, 01:55
by fox
i'll take a look tomorrow, thanks.

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 27 Apr 2016, 08:48
by fox
well, i ran the upgrades up to current schema version and it updated normally, so tbh i'm not sure what went wrong there, but at least it is not broken for everyone

Re: Troubleshooting updates on Ubuntu Server 16.04: Feeds Don't Update

Posted: 27 Apr 2016, 17:55
by surfrock66
I was letting my install auto-update, but now I'm gonna manage updates through git...I wonder if my codebase was older than I thought.