new feeds not loading

Questions about http://online.tt-rss.org go here
ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

new feeds not loading

Postby ginahoy » 01 Feb 2010, 09:27

When I log in, there's a red error message at the top:
"Update daemon is not updating feeds."

When I click on the error message, I get this:
Update daemon is taking too long to perform a feed update. This could indicate a problem like crash or a hang. Please check the daemon process or contact instance owner.
Last update: 2010.02.01, 3:06


what to do?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 01 Feb 2010, 10:11

Well, looks like it works now. :)

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 01 Feb 2010, 18:27

It was broken for most of yesterday PM. I guess it's nice when things fix themselves :D

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 01 Feb 2010, 19:43

Works now = I have restarted the process. :D

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 11 Feb 2010, 05:21

Fox, looks like the process might need to be restarted. I'm getting same error as before.
Thanks, David

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 11 Feb 2010, 09:25

Hmmm. It could be that one of the feeds is hanging the update daemon. Well, let's try it again.

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 11 Feb 2010, 09:53

all is well again. Thanks

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 15 Aug 2010, 20:26

Hey Fox, the Online version appears to be down. Same error as noted in OP. Thx

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 15 Aug 2010, 21:16

Looks like the daemon chokes on several feeds in the database and hangs. :(

Code: Select all


ttrss_online=> select feed_url, update_interval, last_update_started from ttrss_feeds order by last_update_started desc limit 2;
             feed_url              | update_interval |    last_update_started
-----------------------------------+-----------------+----------------------------
 http://en.akibablog.net/atom.xml  |              30 | 2010-08-15 12:42:13.072055
 http://accany.wordpress.com/feed/ |              30 | 2010-08-15 12:41:59.498278
(2 rows)


Update attempt for these two feeds have been initiated last, I'll disable them for the time being to see if that helps.

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 15 Aug 2010, 21:35

Ok. Error message is now gone and I received feed for this forum (my earlier message, but not yours, yet). However, I have about a dozen news feeds (NY Times, AP, local newspapers) and none of those updated. I know there's a lag in TT-RSS so maybe I just need to chill for a little while...?

BTW, the two bad feeds you listed are not mine :wink:

UPDATE: Two more feeds have now updated.
UPDATE: All feeds have updated :D

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 25 Aug 2010, 18:23

I have added some sort of basic protection against stuck update processes, we'll see how it goes. :)

(see http://github.com/gothfox/Tiny-Tiny-RSS ... 9d96c3a7a8)

ginahoy
Bear Rating Disaster
Bear Rating Disaster
Posts: 66
Joined: 02 Jan 2010, 07:10

Re: new feeds not loading

Postby ginahoy » 26 Aug 2010, 04:54

Hey Fox, your new code may have a bug... my feeds haven't updated today. Or maybe a coincidence?

My feeds normally display well over a hundred news stories by now. I'm not seeing any error messages.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: new feeds not loading

Postby fox » 26 Aug 2010, 13:08

Yeah, lol. I kinda threw away the baby with the bathwater there a little bit. :) That is fixed now.


Return to “Online”

Who is online

Users browsing this forum: No registered users and 2 guests