404 on certain scripts and style sheets

Questions about http://online.tt-rss.org go here
xavier
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Nov 2010, 14:37

404 on certain scripts and style sheets

Postby xavier » 17 Nov 2010, 15:06

Hello

I'm getting this errors on my Chrome console.
This is Chrome 7.0.517.44

Code: Select all

http://online.tt-rss.org/infobox.css?1289799814
Failed to load resource: the server responded with a status of 404 (Not Found)

http://online.tt-rss.org/localized_js.php?1289799814
Resource interpreted as script but transferred with MIME type text/plain.

http://online.tt-rss.org/offline.js?1289799814
Failed to load resource: the server responded with a status of 404 (Not Found)

http://online.tt-rss.org/offline.js?1289799814
EXCEPTION: Exception: ReferenceError: dojo is not defined
Function: init()


This last exception shows an alert and the progress slider stops forever.

I can access my feeds from Firefox... but I don't get my usual 3-pane view, although I select it on the preferences panel.

Any help would be appreciated.
-Xavier

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: 404 on certain scripts and style sheets

Postby fox » 17 Nov 2010, 15:56

Given that no code in tt-rss currently references offline.js, you might want to refresh your browser cache or poke your http proxy.

I can access my feeds from Firefox... but I don't get my usual 3-pane view, although I select it on the preferences panel.


That might have not been merged to Online yet. Theme support is currently work in progress due to UI overhaul.

xavier
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Nov 2010, 14:37

Re: 404 on certain scripts and style sheets

Postby xavier » 19 Nov 2010, 01:38

I'm lost. I cleared the browser cache and still got the same error.

These are the headers that Chrome shows

Code: Select all

Request URL:http://online.tt-rss.org/tt-rss.php
Request Method:GET
Status Code:200 OK
Request Headers
Accept:application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Cache-Control:max-age=0
Referer:http://online.tt-rss.org/tt-rss.php
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Response Headers
Cache-Control:no-store, no-cache, must-revalidate, max-age=0, post-check=0, pre-check=0
Connection:Keep-Alive
Content-Language:en-us
Content-Length:10226
Content-Type:text/html; charset=utf-8
Date:Mon, 15 Nov 2010 05:43:33 GMT
Expires:Mon, 22 Dec 1980 00:00:00 GMT
Keep-Alive:timeout=15, max=61
Last-Modified:Mon, 15 Nov 2010 05:43:34 GMT
Pragma:no-cache
Server:Apache/2.2.9 (Debian)
Vary:Accept-Encoding
X-Powered-By:PHP/5.2.6-1+lenny9


Any hints? Thanks!
-Xavier

xavier
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Nov 2010, 14:37

Re: 404 on certain scripts and style sheets

Postby xavier » 19 Nov 2010, 08:41

As far as I know, I'm not using any proxy (I have regular DSL home connection). Since Firefox is getting a different thing from the same machine, should I conclude that Chrome is lying to me when "about:cache" shows an empty page?

The Firefox headers, just in case

Code: Select all

http://online.tt-rss.org/tt-rss.php

GET /tt-rss.php HTTP/1.1
Host: online.tt-rss.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0C)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.8,ca;q=0.5,es-es;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Cookie: ttrss_sid=(...); ttrss_lang=en_US; feedTreeSaveStateCookie=(...)

HTTP/1.1 200 OK
Date: Fri, 19 Nov 2010 05:22:50 GMT
Server: Apache/2.2.9 (Debian)
X-Powered-By: PHP/5.2.6-1+lenny9
Content-Language: en-us
Expires: Mon, 22 Dec 1980 00:00:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, max-age=0, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: ttrss_lang=en_US; expires=Sun, 19-Dec-2010 05:22:50 GMT
Last-Modified: Fri, 19 Nov 2010 05:22:50 GMT
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 2858
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: text/html; charset=utf-8


Thanks for your time.
-Xavier

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: 404 on certain scripts and style sheets

Postby fox » 19 Nov 2010, 09:45

That's strange. Do you still get offline.js-related errors? Can you do view source on tt-rss.php and see if it references offline.js at all? The correct version should have lots of dojo-related stuff inside.

One more suggestion - if you ever used offline mode, it might be a good idea to remove Google Gears storage for online.tt-rss.org. That might be screwing things up in Chrome.

xavier
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Nov 2010, 14:37

Re: 404 on certain scripts and style sheets

Postby xavier » 19 Nov 2010, 13:00

I'm not aware of having used offline mode. However, there was this dir in my profile

Code: Select all

\UserData\Default\Plugin Data\Google Gears\online.tt-rss.org
. After deleting it, everything was fine again.

I'm very anoyyed with Chrome
* not making it easy to view/delete the gears data
* not deleting it for me when I ask it to delete the cache

Thanks for your time and your hints.
-Xavier

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: 404 on certain scripts and style sheets

Postby fox » 19 Nov 2010, 14:25

Gears settings are hidden in wrench menu -> options -> under the hood -> gears settings. Not exactly straightforward, yeah. Glad it's working for you now.


Return to “Online”

Who is online

Users browsing this forum: No registered users and 2 guests