LibXML errors the past few days

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

LibXML errors the past few days

Postby smeerbartje » 08 May 2014, 09:29

I recently have som errors with feeds. It happens since a few days I think. I'm running the latest trunk version (up-to-date). This is what I get:

Feed: http://brett.trpstra.net/brettterpstra
Error: LibXML error 76 at line 9 (column 8): Opening and ending tag mismatch: link line 7 and head

Feed: http://feed.katiefloyd.me/
Error: LibXML error 76 at line 9 (column 8): Opening and ending tag mismatch: link line 7 and head

I also checked both feeds in a couple of online validators and they seem to be correct. Therefore I suppose something is wrong in either my server configuration or in the (trunk??) version of TTRSS I'm using. Now my question: do above mentioned feeds work in your TTRSS installation?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 08 May 2014, 09:41

Don't post support questions in development. Check the stickied thread in support. Try thinking before you post.

e: I have no idea wtf "some validators" are but they may not necessarily require strict XML validity. On the other hand, libxml does.

smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

Re: LibXML errors the past few days

Postby smeerbartje » 08 May 2014, 22:04

Dude, relax, will you? I thought that the amount of "tolerance" of the parser could be a developer-question. Therefore I have posted it into this section. I didn't expect an answer like this. Can you please move the question to the support section?

To be on-topic: I tried the W3C validator. It says that the XML is a valid Atom 1.0 feed, see this link. So why does libXML throws such an error? And is it possible to parameterize the parser so ttrss users can determine if they want such (well-known-feeds) to be accepted or not?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 08 May 2014, 22:42

Maybe libxml-related questions would be better directed to libxml developers.

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: LibXML errors the past few days

Postby feader » 08 May 2014, 23:22

To throw a totally uneducated guess into this: Both feeds have a stylesheet like

Code: Select all

<?xml-stylesheet type="text/xsl" media="screen" href="/~files/feed-premium.xsl"?>

included, which might explain why they behave so strangely (e.g. Firefox doesn't show its normal feed interface with them, but a wild mess of text instead – could well be that the custom stylesheet overrides its own).

To test it, you can dump the feed source into a local file on the machine you host ttRSS on, delete the stylesheet line and subscribe the URL http://localhost/your/path/here. Report back, please.

smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

Re: LibXML errors the past few days

Postby smeerbartje » 08 May 2014, 23:32

Cool, will do that tomorrow early morning. Will let you know the outcome...

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: LibXML errors the past few days

Postby feader » 09 May 2014, 00:42

Eh, I'd be glad if you still tried, but you probably can simply suffix the URLs with ?format=xml to get the XML, Firefox displays them nicely then. I took a look at them with Safari, which can't display feeds anymore, and Lo – the pages render nicely there, and you'll also see a link to raw XML.
I also believe to recall that that was discussed here some short time ago.

lotrfan
Bear Rating Disaster
Bear Rating Disaster
Posts: 73
Joined: 18 Mar 2013, 04:42

Re: LibXML errors the past few days

Postby lotrfan » 09 May 2014, 01:04

It doesn't work with http://madoka.volgo-balt.ru/myfeedsucks/ (see viewtopic.php?f=1&t=2978)

It looks like it's sending back HTML instead of the actual feed.

Adding the "?format=xml" makes it send back the actual feed (at least for the first one)

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: LibXML errors the past few days

Postby sleeper_service » 09 May 2014, 01:22

smeerbartje wrote:Dude, relax, will you?


you talk like you're new here, but it says you've been around for a year... *scratching head*

smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

Re: LibXML errors the past few days

Postby smeerbartje » 09 May 2014, 10:13

True, I'm here a while... what do you mean with that? You mean I should know you're an artist with keen observation skills???
Last edited by sleeper_service on 09 May 2014, 17:53, edited 1 time in total.
Reason: correcting some typos :)

smeerbartje
Bear Rating Disaster
Bear Rating Disaster
Posts: 67
Joined: 04 Apr 2013, 23:24
Contact:

Re: LibXML errors the past few days

Postby smeerbartje » 09 May 2014, 10:16

feader wrote:Eh, I'd be glad if you still tried, but you probably can simply suffix the URLs with ?format=xml to get the XML, Firefox displays them nicely then. I took a look at them with Safari, which can't display feeds anymore, and Lo – the pages render nicely there, and you'll also see a link to raw XML.
I also believe to recall that that was discussed here some short time ago.

That's it!!! Simply adding format=xml solved it, thanks!

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 09 May 2014, 13:11

it's not about xsl stylesheets, those idiots literally feed pre-parsed html shit to tt-rss

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>BrettTerpstra.com — provided by FeedPress</title>
<link href="/~files/feed.css" rel="stylesheet" type="text/css" media="all">
<link rel="alternate" type="application/rss+xml" title="BrettTerpstra.com" href="http://brett.trpstra.net/brettterpstra">
<script type="text/javascript" src="http://static.feed


libxml or tt-rss or w/e else has nothing to do with it, it's all about that horribly broken shit feed generator
if op spent like one minute reading myfeedsucks diagnostic output instead of posting here

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: LibXML errors the past few days

Postby feader » 09 May 2014, 13:52

fox wrote:it's not about xsl stylesheets, those idiots literally feed pre-parsed html shit to tt-rss
[…]
libxml or tt-rss or w/e else has nothing to do with it, it's all about that horribly broken shit feed generator
if op spent like one minute reading myfeedsucks diagnostic output instead of posting here


No. If you curl it down, e.g. curl http://feed.katiefloyd.me/, you get something like

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!--Generated by Site-Server v6.0.0-20140506.7-185 (http://www.squarespace.com) on Tue, 06 May 2014 23:30:48 GMT
-->
<?xml-stylesheet type="text/xsl" media="screen" href="/~files/feed-premium.xsl"?>
<rss [Seemingly well-formed feed here]

and if you curl with ?format=xml, you get the same. The html you quoted looks a lot like the stuff in the feed, so I conjecture that it is the result of a xsl transformation that doesn't happen if you give the parameter.

What is actually strange is that according to OP, it is validated by the w3c checker, maybe they are ignoring the stylesheet?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: LibXML errors the past few days

Postby fox » 09 May 2014, 14:14

protip: tt-rss is not curl

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: LibXML errors the past few days

Postby feader » 09 May 2014, 14:59

fox wrote:protip: tt-rss is not curl

Fair enough. :oops:


Return to “Support”

Who is online

Users browsing this forum: No registered users and 0 guests