Updater can't extract tarball

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
User avatar
lordofthemoon
Bear Rating Trainee
Bear Rating Trainee
Posts: 10
Joined: 01 Apr 2013, 22:36
Location: Glasgow
Contact:

Updater can't extract tarball

Postby lordofthemoon » 04 Apr 2013, 21:45

Hi,
I installed 1.7.5 a few days ago and I see that 1.7.8 is out now. I tried to use the updater to update to the newest version and got the following in the window:

Ready to update.
Work directory: /var/www/ttrss
Checking for tar...
Checking for gunzip...
Checking for latest version...
Target version: 1.7.8
Proceeding to download...
Downloading distribution tarball...
Saving download to /tmp/tt-rssKVpqbS
Extracting tarball...
Error while extracting tarball (RC=2).


If I go into /tmp, I can manually unzip the tarball (as root, as the file was created as the Apache user) so tar is installed and working. If it matters, I'm using the Raspberry Pi Raspian Wheezy distro.

I have, however, been able to successfully update manually.

User avatar
sboulema
Bear Rating Trainee
Bear Rating Trainee
Posts: 15
Joined: 22 Mar 2013, 12:30

Re: Updater can't extract tarball

Postby sboulema » 04 Apr 2013, 21:51

The updater will extract the tarball and make a backup in the /var/www/ dir, so the apache user needs write access to that dir

User avatar
lordofthemoon
Bear Rating Trainee
Bear Rating Trainee
Posts: 10
Joined: 01 Apr 2013, 22:36
Location: Glasgow
Contact:

Re: Updater can't extract tarball

Postby lordofthemoon » 04 Apr 2013, 23:20

I've checked and the apache user does have access to /var/www (it's owned by root, but the apache user's group is the group of the directory and the group has write permissions).

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Updater can't extract tarball

Postby joshp » 12 Apr 2013, 21:26

Same issue, permissions are set correctly, but I am getting the same error.

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Updater can't extract tarball

Postby joshp » 12 Apr 2013, 21:36

Apparently I needed to "apt-get install php5-curl", following instructions on site. But even after that, same issue.

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Updater can't extract tarball

Postby joshp » 12 Apr 2013, 21:40

Apparently I needed to "apt-get install curl libcurl3 libcurl3-dev php5-curl", following instructions on site.

Note, you not only need to install php5-curl, but the straight up curl package as well. Hope this helps.

Flaim
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 14 Jun 2013, 02:56

Re: Updater can't extract tarball

Postby Flaim » 14 Jun 2013, 02:57

Is it hard coded to expect to be in /var/www?

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Updater can't extract tarball

Postby sleeper_service » 14 Jun 2013, 09:22

Flaim wrote:Is it hard coded to expect to be in /var/www?

no


Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests